Batch animation preview

Hi, would it be possible to also implement a batch animation viewport export. Right now it only exports the first frame, so I have to manually select scene by scene and export them. Or am I missing something?

Thank you.

Hello Mantis,

Sure, we are planning to add this feature soon. Thanks for mentioning it!

Best regards,



Hi, any progress on this? Seems like a pretty big oversight to have missed in earlier development.


It is on the way for sure. Thanks for the reminder!



1 Like

Hi Attila, any update on this?

Small bump, is there an update planned soon?

Hey Mantis,

I’m sorry for the late reply!

Sure thing it is coming in the next update. Until then I can also offer you a workaround if you have tyFlow installed!

Setup a common output for each of your setups pointing to the directory where you want your previews

Then open up the bake settings window

Paste the following script to the custom script area: tyPreview output_type:0 output_filename:((getFilenamePath rendOutputFilename) + (getFileNameFile rendOutputFilename) + “.mp4”)

Once you press RUN the scene manager will do all the steps to set up your cameras, etc, and then it will run a tyPreview and it will tell it to create an mp4 to the same directory as you described before, but it will change the extension to mp4.

I hope this will help.


1 Like

This finally got implemented and you can try it out in the latest beta:


Great, Thanks Peter.

Another nice one, thank you, Peter !

Is anyone else having issues with the batch animation preview? And is there any support documentation for this?

When I render it seems the only option is to output jpegs (but its dropping quite a few of those) and then crashes just before completion…



The batch animation preview uses the built in 3ds Max Make Preview feature under the hood or if you have tyFlow installed then you can use the tyPreview which is a great tool.

Regarding the crash and the dropped frames I don’t have an exact answer. If you can send us a file where we can recreate the issue we can look into that.


Batch rendering with tyPreview does not seem to preserve tyPreview setting for all sequences.
It renders the very first one sequence fine, but all the others seem to be rendering with tyPreview settings back to default. (i.e. no antialiasing selected etc)
Is there any way to overcome this?

One thing to note though is that we’re using Tyflow Beta with Max 2022, so I wonder if it’s tyFlow beta issue or Pulze’s?


Hey @inkvisual

Thanks for the heads up. I’ll make some notes and look into it as soon as I can.