Batch Setup to Batch Render


I’ll say it again, the tools you develop are really cool! :sunglasses:

Unfortunately, today we are stuck in our workflow as soon as we want to submit the renderings in network. Which happens very often :blush:
No matter how complex the views configured in Scene manager are, the conversion in the batch always ends with an error.

Do you have an idea how to fix this?
Thanks guys

Hello Sandrine,

Thanks for the kind words :slight_smile:

Could you tell us a bit more about the problem and send a few screenshots so we can see what would you like to bake and what is the outcome. You could also send us your scene to and we can have a look at it.



You’re welcome :blush:

Yes of course, for example on this setup
There are two cameras, the only thing that changes is the ceiling that is visible or not to the camera.
After the back setups in the batch render of 3ds max here is the result

The scene state are missing
And it is always this error.

Okay that is great thanks.

Seams like SM fails to create the Scene States. Could you please check if Scene States works manually. If you go to Tools > Manage Scene States… can you see and interact with the window. If not then I’m afraid you will have to reset your ENU folder and then try it again. If it works manually, so you can create two states and switch between them then we will have to go a bit deeper and ask for the file.

Let me know how it goes.


Ok, I followed what you said
Either create manually scene states.
I had to re-initialize the ENU folder as you said :wink:

Once done, the manual creation of scene states worked, as you can see

On the other hand, the scene manager bake still doesn’t work. The scene states are missing :confused:
Do you have another idea?

Unfortunetly that is not the correct window. You have State Sets there but we would like to check Scene States. See below:


Hello Sandrine :slight_smile:

Switch to Render Manager and forget about this s**t :slight_smile: :slight_smile:

1 Like

OK, it’s ok after reset, the windows “Manage Scene States” has been displayed
And the pulze presets during the conversion are finally there and not missing

On the other hand, a new problem during the conversion on the rendering path. It adds before the extension" 0000".
I put you the screenshot

And even by renaming and correcting the name by hand
In any case, it crashes during the submission indicating " Error writing to file"

Okay great that is progress, but unfortunetly from this point it is up to backburner and max to do the rest.

I guess the “Error writing to file” message suggests that you don’t have permission, space, etc to save the file.

Can you submit the same file without errors without the baked batch render?

Regarding the extra digits before the extension, we add them on purpose and currently there is no way to change it.

By creating the job manually, using the same camera and the same path, the submission goes smoothly.
As you will see, it is exactly the same path as the previous capture

Can you send us the file to and we will check whats going on, but since we are talking about backburner we can’t promise anything. If it’s directly our fault then we will let you know what is the workaround.