Change network interface?

I have a workstation at home and connect back to the company network via VPN. When I first set up Pulze, it gave me a choice of network interfaces. One was my local LAN, the other was the company LAN. I mistakenly chose my local LAN and of course am getting a “Replier error” from the render node.

I understand from other posts that VPN connectivity is not yet supported, but I would like to make certain that I’ve tried everything on my end to get it to work.

I don’t see a way to go back and select the other network interface. I uninstalled and reinstalled Pulze, but when I went through the setup again it remembered my settings and skipped the network interface selection.

Is there a way to do a clean uninstall/reinstall in order to get that network interface selection back?



Yes, currently Pulze will not work on a simple VPN connection due to the fact that VPN is a one way connection. We have plans for the near future to support it.

To reset your settings please delete the content of C:\Users<username>\AppData\Roaming\Pulze Service. Start Pulze again and you should be able to select the correct network.


Welp, I have a confirmed connection! My render node (at work) saw and connected to my workstation node here at home, and my workstation node at home shows the render node as available and online. I’ll try an actual render tomorrow. Thanks for your help!

Hi, I’m looking for a similar solution. Could you reply if this worked even if it’s not supported? Also what kind of VPN are you using to connect to your work?

Kind regards.

It worked. I was able to submit a job from my workstation at home and it successfully completed the job on our render node in the office.

Our VPN connection is via GlobalConnect. The thing I had to make sure to do as mentioned earlier was choose the virtual ethernet connection generated by the VPN. I had to set the gateway as, and it works fine.

Hope this helps!

We did some more testing yesterday. Per the instructions in the licensing FAQ:

If you are planning to purchase several licences then the best practice is to use a general user account name which can be accessible for all the users in your organization.

… my co-worker installed Render Manager at his house and used my account to log in. He is also connected to the company network via VPN. When everything was up and running on his end I could see his machine on Render Manager, but it had a “device is unable to receive commands” error on my screen.

So I installed Render Manager on the virtual machine that we use as our Backburner render manager and on that machine I started a new Network Pool and had the render nodes join that pool. He and I both joined that pool as well. He had to log out and back in to Render Manager a few times, but eventually he was able to see all 5 nodes (his workstation, my workstation, the “render manager” on the virtual machine, and our two normal render nodes). This is where it gets weird.

On his computer, he sees all 5 nodes. On my computer, I see all 5 nodes. The “render manager” on the virtual machine only sees 4 nodes: itself, the two render nodes, and one of our workstations. For a while, that 4th node would switch between saying it was his workstation and my workstation every couple of seconds. This morning, it seems to have settled into just showing his workstation.

I submitted a couple of render jobs last night and my coworker could see them in the jobs tab on his end, so this may end up working. We’re going to do some “collision” testing today to see what happens when we both try to saturate both nodes at the same time.

Anyways, I know that VPNs aren’t supported, I just wanted to give an update on what our experience with it has been so far.