Connection lost because of overload


While I was rendering a sequence my main workstation, which is the distributor device, gave me a BSOD with Stop code: ATTEMPTED_SWITCH_FROM_DPC. Looking at the Render Manager from one of my nodes the error for the workstation was: Connection lost due to overload (or something very similar).
Is this a known issue? Should I do something to prevent it from happening in the future?


I am having the same issue. Unfortunately due to a lack of available ethernet ports the node in question is connected through WIFI - could this potentially be causing the problem?

I am having a similar issue here. Although it is not very often, random PCs in our collection will randomly get this error. But when we look at the PC in question, there appears to be no issue. Could this be caused be small interuptions in the network or internet connection?

I think they have included this error in the latest additions in FAQ’s. Here is what it says:

"What does it mean: connection lost because of overload?

It means that the render node or workstation was not able to keep the communication with the Render Manager pool while rendering. To overcome this problem try lowering the usable cores for rendering. Setting the affinity to all cores minus 1 or 2 should do the trick.

Please also check your memory usage, if your computer runs out of RAM it can also lead to crashes and lost connections."

Hi, just bumping this thread as we have been having the “Could not reconnect to ‘machine name’ because of overload”.

Is this purely due to CPU/RAM usage or could it be to do with network issues as well? Obviously this is pretty important as we need to be able to trust if we send a number of renders rendering overnight they will render and this won’t be an issue.

For anyone that has had this issue to lowering the useable cores for the CPU fix the issues? Also is it the Master or the other machines you need to lower the CPU use?


Lowering by 1-2 cores on master machine as well as on my nodes seems like it fix the issue. I haven’t seen that error since then.