Issues with animations and every-nth-frame, RM/SM

Hi, there seems to be an issue in the latest release of Render Manager and Scene Manager where Render Manager doesn’t set the animation range correctly when the Max file is saved in “Single Frame” mode. It’s especially noticeable when sending jobs set to every-nth-frame, as they will reach >100% completion in the Render Manager list.

Specifically, what we noticed is that when the Max file is saved with its frame range (NOT the settings in Scene Manager) set to Single Frame, any jobs submitted to RM from that file will do several things:

  • The Render Progress dialog will not appear on those nodes
  • Settings such as Every-Nth-Frame will not be respected. Possibly the frame range settings in SM will be completely ignored. What we saw was that on an every-50th-frame job every frame was being rendered.
  • In Render Manager, progress on these jobs will not be tracked or managed correctly. In our 50th-frame jobs, we saw shots reach >100% as they rendered more frames than they were supposed to.

The workaround for us has been simple enough: none of this happens if the Max file is saved in either “Active Time Segment” mode. We’re sure this was not an issue before the latest hotfix.

If you need any more info, let us know!


This issue seems to be a little different than I first realized. The problem is not with SM, but strictly with the latest release (2.1.8) of RM. Almost any job submitted using every-nth-frame will render incorrectly, and actually render every frame in the range, ie 0-100 every-50th will render 0,1,2,3… instead of 0,50,100. The 3ds Max Render Progress Dialog also does not appear anymore, which seems unusual.

After some additional trial-and-error, it seems that the solution is to set 3ds Max to “Frame Range”, setting the nth-frame options in Max, not in Render Manager, and then submitting the job from the open copy of Max.

Bumping this now that the holidays are done.