Let Pulze create missing folders

Setting up custon output save paths where different cameras are supposed to go in different folders, it seems I have to create all of these folders in advance and double check that the names match what’s set up in Pulze Output path.

Would be nice if Pulze created whatever folder necessary if they are missing, instead of just giving and render error because the path doesn’t exist.

Maybe just a little checkbox in the Render Output - Common frame saying " automatically create folders".


Maybe I misundertand your problem, but you can easily automatize folder creation by camera, using the camera name tag as folder, in the various naming options SM proposes ?
Or I don’t understand what you need :slight_smile:

I’ve been able to use the camera name or free text as folders in the output path in pulze. But pulze doesn’t actually create this folder on the hard drive so if I don’t manually create it in windows explorer, when I send the render to backburner it won’t start because the output folder doesn’t exist.

Ohhhh ok, it’s because of BackBurner … No problem with Render Manager :wink:

Gotcha, thanks for clearing that up :slight_smile:

Yes we aware of this. If you use SM batch render or Render Manager we will create it, but in other cases we don’t. The render output module is updates pretty frequently, whenever you change a value, add a new item, remove one it always regenerates itself, so each time you do it would create the folder and most likely you would end up with a dozens of folders that you don’t need. Because of this we would prefer a button to do this.

Until then you can use this pre render script with Backburner to do it:

fn createDirectory filepath=
	if (doesFileExist (getFilenamePath filepath) == false) then
		makeDir (getFilenamePath filepath) all:true

if (rendSaveFile == true) do
    createDirectory rendOutputFilename

Save this snippet as a preRender.ms file and load it in to the scene manager Script File module or just in the native render settings dialog.

Thank you for this workaround. Fantastic support as always!