Missing PSD Manager plugin

Hi
I was looking for a solution for RM not seeing the PSD Manger plugin on either the workstation or the render nodes. I saw an earlier post about this but I wasn’t sure if it ever got resolved. I am using PSD Manager 5.0.3.

When I first started using RM this was not an issue, so I’m not sure what has changed. I don’t use RM enough to be able to pinpoint when the change happened.

Backburner can see the plugin fine and this is what I usually use for PSM jobs. Unfortuntely, in trying to reset some of the Backburner machines I get the following on the workstation:

‘ERR Error message: 3dsmax adapter error : Autodesk 25.3 reported error: :8: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module’s documentation for alternative uses’

I’d rather use RM but if there isn’t a solution, maybe you could tell me what the above BB error code means (apologies if I’m being cheeky asking this)

Hi @Montage-Studio

Thanks for the post. Let me start with the easier and not related to Render Manager.

‘ERR Error message: 3dsmax adapter error : Autodesk 25.3 reported error: :8: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module’s documentation for alternative uses’

This is an error message from python about the depracted module. I believe this is coming from Connecter or Megascan plugin. This should be harmless and should not cause any issues to your rendering.

As for PSD Manager issue, which version of Render Manager are you using?

Hello, I may have the same issue with the psd manager plugin showing as missing on our node computers. I am using version render manager version 2.2.12 (2024-04-16)

I think it might be the way PSD Manager installs itself, or more to the point, where!
In the plugin configuration file (3dsmax>en-US>plugin), it points Max to the pluging here: ‘psdmanager=C:\Users\Public\Documents\cebas\3dsMax2023_x64\psdmanager’

However, a while ago, Windows had its file structure renamed so that ‘Documents’ is now called ‘Public Documents’. I have no idea if this makes a difference as it still works.
You can edit the plugin file in notepad and put the correct address and see if that works.

When I tired it, PSD Manager disappeared from 3dsmax so I have had to revert back. I haven’t really done anything else to solve it. I did try copying the plugin to the plugins folder but that didn’t make any difference - maybe I copied the wrong bits?

One thing I did notice is that both Scene Manager and Render Manager don’t always see PSD Manager i.e. in the plugins tab of SM it’s sometimes not there even though it’s in the scene and RM doesn’t show it when looking at the Analytics tab - it used to.

I’d be interested to know what your machine shows - can you see PSD Manager in the Analytics tab?

Cebas are very good at finding solutions and it may well be that they can suggest a work-around. You can probably get a faster response if you contact them on Discord.

Thank you for your reply. The confusing thing is that I can see Psd Manager 5.0.3 in Analytics for all machines. So Pulze knows it’s there, but still shows up in missing requirements and I have to turn it off to be able to submit the render job.

The path C:\Users\Public\Documents\cebas… in the plugin.ini file is correct. Windows simply shows you a different path in Windows Explorer to make it look “better” and localize it. For example in a German Windows the path shows like this in Windows Explorer.
image
By clicking in the explorer address bar you will magically reveal the real folder name.

I have extensively researched 3 years ago on why Pulze Render Manager shows the incorrect missing plugin warning. Back then it was specifically looking for psdmanager.dlv in the .max scene file when submitting the scene, but not properly searching for plugins on the render nodes. So it would complain about a missing plugin that was not actually missing.
I sent 3 email replies to a request for more information in April 2021 with my test results but never got a reply. So I do not know if and what was fixed in the meantime.
Maybe it was fixed back then by not looking for it on the workstation, knowing that it will not be able to properly detect it on the render nodes?
Does “not seeing the PSD Manger plugin” cause any actual issues for you?

Best regards,
Daniel Schmidt - psd-manager Developer

I have done some new tests with 2.2.12 and the way psd-manager 5 is detected was improved a lot since my old test. Pulze seems to properly follow plugin.ini paths now and reads version information from the DLL. It also finds the plugin when placed directly in the Plugins directory. So not sure what would lead to it not being recognized now.
My guess would be its stumbling over something in the plugin.ini or reading from the wrong language version of the plugin.ini. The cebas Product Manager makes an entry in each languages plugin.ini, so that also shouldn’t matter.
Happy to test your plugin.ini files here.

Daniel Schmidt - psd-manager Developer

Hi Daniel,
I know we are having a similar chat over on your Discord server, here are two screenshots of the error I receive from Pulze. Pulze is contradicting itself here as it states in Analytics that psd manager is installed but on submission of a render job it says that the plugin is missing? The job will render when I click ignore (but not save the psd file).


To clarify, the plugin.ini file is pointing to the Cebas folder like this…

[Directories]
psdmanager=C:\Users\Public\Documents\cebas\3dsMax2024_x64\psdmanager

  • Pulze? any ideas why this might be?

Pulze? Any ideas why this might be?

Hey @studio5

Could you please reach out to support@pulze.io with a log from your computer (https://www.pulze.io/faq/how-do-i-collect-my-render-manager-logs-and-send-them-to-pulze-support) and we will get to the bottom of this issue!

@DanielS Thanks for joining the discussion. I do remember this issue a few years ago. Back then I believe the problem was that the plugin.ini file was pointing to another .ini file that was pointing to the plugin location and this was not supported by Render Manager and it still not.

We search for plugins in the /plugins directory as well any folder that is mentioned in any of the plugin.ini or Plugin.UserSettings.ini files and we also check ADSK_3DSMAX_PLUGINS_ADDON_DIR environment variable.

I believe looking at the logs and reproducing how the psd manager is installed we will figure out the problem!

I see the wrong missing plugin warning here too, always. This is on a single PC! It correctly finds the plugin and shows it under Analytics (correct version number). When submitting a job it lists “Psd Manager” as requirement, but does not show a version number (shouldn’t it?). It then warns about not finding nodes to render it, because of Missing Psd Manager plugin. (There is no warning shown until atleast 1 computer is in node mode.)
I’m fairly sure you can reproduce it just by copying the trial plugin https://www.cebas.org/psdmedia/psdmanager_5_trial.zip into your plugins directory.
Render Manager does find the plugin correctly (I tried different locations). I think the way Pulze Render Manager compares the job to the node plugin requirements may be the actual cause. There should be no way to get a missing Plugin warning for the same PC that submitted the job.
I also setup a second node and get a warning for this other PC too (this node just has 2024 installed).

This is always in the reqs section of PulzeRepository/stats/…json (version is null?):

{"category":"software","type":"plugin","name":"Psd Manager","value":{"id":"psdmanager","version":null}
"plugins": [

And this from “…AppData\Roaming\Pulze Service\myPrograms.json”

					"plugins": [
						{
							"id": "psdmanager.dlv",
							"name": "Psd Manager",
							"path": "C:\\Users\\Public\\Documents\\cebas\\3dsMax2024_x64\\psdmanager\\psdmanager.dlv",
							"version": {
								"major": 5,
								"minor": 0,
								"patch": 4
							},
							"_id": "3dsmax_2024_psdmanager"
						},

image


When dropping the requirement the scene renders as expected. Having to do this every time is very annoying for the users. Please have a look.

Daniel - psd-manager Developer

Hi @DanielS

Thank you! We found the issue and we will publish a new version soon.

Great, I found it too. The plugin id is “psdmanager” in the jobs .json but “psdmanagr.dlv” in the myprograms.json

Changing the id to psdmanager.dlv in the xxxxx.json job file in C:\Users<usrename>\AppData\Roaming\Pulze Service and restarting Pulze solves it. Was testing this before, but didn’t realize that the job in the Repository is just a copy.

While you are at it - the official product name is “psd-manager” and not “Psd Manager” - thank you.