Not working, once again

Once again your product is not working. When I uncheck Visible to Cam in the Objects tab nothing happens. This is also true for the layers tab. I’m working with Fstorm.

Fix this ASAP please, I paid for this product and I can’t use it the way I need it!

Hi @joep.swagemakers

Happy to help you out and figure out what goes wrong. I made a quick test both scenarios.

Here is a screenshot when using the Objects module:

and when using the Layers module:

Please note that if you want to use Visible to Camera, you need to swich to By Object in the object properties in order to take effect.


Yes it’s always set to by object and I do the same things as you are, but objects are still visible to the camera. I tried restarting Max, re-adding the object in the scene manager, regrouping the object but nothing.

I just tried something else, when I add the objects in the group seperately then it works but when I add the group it won’t work. The problem is group objects. Please don’t tell me you don’t support group object because if I have to add all objects to the manager it will be a mess, and moreover scene manager can’t handle it.

So what to do about groups?

Edit: I tried the not visible option by layer but I get the same problem, it does nothing.

Before I dive in and try to reproduce this with groups, is it working if you would do it without Scene Manager? Could you share a screenshot what you are after and I will do exactly the same!


What do you mean dive in? It’s super simple to just create a group and then make it not visible to the camera. I can send you a screenshot but literally a group, added to the objects tab in SM and then switch off the option “v. to cam”. I just tried it with a new group with two boxes and it just does not work!

This is the 5th ot 6th time I get a bug similar to this while I’m doing a project and I’m on a deadline. Do you guys even test your software before you release it or do you let paying users do it?

Ok I thought it is more complicated. I can confirm Visible to Cam is not working with groups, because Scene Manager only grabs the head of the group and it only sets this property for that not for its children. Since I was not aware that this is not working we didn’t take actions.

Will fix this and get back to you!

Don’t bother I’ve switched to Scene States now. It takes longer to set it up then SM but at least it works.