One machine cannot connect to pool: Requirements Error

This machine (workstation) used to be a part of the pool but now it’s having issues. The user reported that they couldn’t see any other machines in the pool. After trying to rejoin the pool, it cannot find the pool automatically anymore. I tried connecting manually to a few of the other machines still in the pool and I get this error in the manager (IP addresses obfuscated): “Requirements error: ##.##.##.## | Gateway”
The Pulze log says basically the same thing:
“localnetwork.localdevice”,“fn”:“check_device_requirements”,“code”:“00”,“type”:“00”,“msg”:“Requirements error on: ##.##.##.## | Gateway”,“time”:“2023-09-26T15:13:27.808Z”,“v”:0}

Some things I’ve tried so far:
• rebooting
• deleting AppData\Roaming\Pulze Service and restarting Pulze
• reinstalling Pulze

Any idea what the problem could be?

We fixed it!
In case anyone else has this issue: the machine was physically moved and plugged into our network in a way that caused it to be on a different subnet. We connected it so that it could be on the same subnet, and problem solved!

Hey @asgvis

Yes that could be one solution. There is also an option called Multi network connection that you can enable which will allow Render Manager to reach out to different subnets or VPN connection.