Priority Problem


I’m having a strange issue, or at least one that i think is strange and maybe its perfectly normal with Pulze render manager. I send jobs as normal priority usually but sometimes I want to skip the queue and start rendering this new one I’m sending. So away i go and submit the jobs as high priority. Job done, however when you look at the monitor, it doesn’t assign any nodes to those high priority jobs, ever. it just sits on 0/0. I expected the nodes to finish their current tasks and then jump on the high priority job but it doesn’t seem to work that way.

So i tested further, cleared the queue and resent the jobs high priority again. No nodes were rendering anything but it still didn’t assign them to the high priority job. Still sitting at 0/0. now if i change them in the queue back to normal priority they pick up the jobs.

Some context on my set up. I run a AMD 3990x as my main rig and implement night mode when I’m ready to render. I am about to add a second node to this but at the moment its a one system farm. I went digging in the settings to see if i could see something related to admin nodes not allowed to render high priority jobs but couldn’t see anything.

I’m getting around the issue by setting dependencies at the moment but in theory setting to high priority should take all the resources correct? or am i doing something wrong?

To add to this info, basically it always does the normal jobs first. It never wants to go to the high priority jobs.

Any help would be hugely appreciated. :grin:

Hello Curtis,

Thank you for reaching out and for the detailed explanation.

The solution is simple: The priority feature does not take an action when there is only one PC in the pool.
We will fix it for sure but we did not prepare the Render Manager for this special circumstance. The whole priority is to automatically redistribute the available capacity between jobs.
In your case if there is only one PC rendering then I kindly recommend to suspend the active job and start the more important new one.
Should you have any questions, just let me know.
Best regards,


I thought I replied to this, I’m going more senile by the day.

Thank you for the response, it makes sense. I am fortunate that my single computer is very powerful and I am glad to hear you are taking this specific situation in to consideration for the future. Hopefully wont be one lonely node for much longer and it gets to have a full grown sibling so this is less of an issue :grinning:


We’re experiencing the same issue. The difference is that we have multiple machines in the pool, but none of them picks High priority jobs. They pick Normal and Medium priority jobs without any issues, but completely ignoring High priority once.

Is there any solution or some settings we need to check to solve it?


Hi Adrian,

At the moment the priority settings are just gently dispatching the Nodes between the jobs. So if you stet a job to high priority it does not mean that the Nodes immediately drops their existing job and swap to the new one.
If you really need to start an urgent job then the recommendation is to pause the rest of the jobs and in this case of course the Nodes will immediately jump on the most important one.
It is also an option to use the “Dependencies” feature. It can be set up on the fly as well. So if you would like to over prioritize a job then make the other running jobs dependent to the new one. In this way the Nodes are forced to finish the first job in the queue.
The good news is that in the new version we completely updated the priority feature. There will be an option to simply drag and drop the jobs in the list. So if you drop a job on the top of the list then all the Nodes will work on that one. Of course there will be many options but generally it will be more intuitive and self explanatory. So stay tuned!
Best regards,

Thanks Attila!

Looking forward to the new version. Do you have any indication when it expected to be released?


The closed beta will be available in weeks. If you are interested just let me know.


Thanks. Yes if it’s possible, count me in for beta.


Similar issue here as well.
Normal priority jobs work. Medium and high priority don’t get picked up at all, as if the were suspended.

We have 3-4 render nodes, all of which only recognize normal priority. This severely impacts the amount of jobs we can leave to render during the night.

Thank you Simon for the report.
As I suggested before the workaround is to use the “Dependencies” feature.
If it is clear that one job is more important than the others then make the less important jobs dependent from the first one. It is just a click during the job creation and it can be updated on the fly.

Again, the good news is that in the upcoming version you will be able to setup the general behavior of the job handling according to your needs.

We can’t wait to share it with you :wink:

Best regards,