Render Manager gets Stuck at "Searching for Programs"

Hello and good morning to all!

I have a problem with Scene Manager, i havent used it for a while, about 6-9 months, and i’ve updated to the latest version but it seems to have a problem. It gets stuck at the begining before it fires up where it says “Searching for Programs”. This seems to happen then sometimes it bypasses it and goes forward but most of the times not.

This happens to my pc (Workstation) but also sometimes in the render node.

Any idea why?

Hi @mfountouklis

Thanks for the report. It is hard to tell just from this, could you please follow this guide and send us some logs from the faulty pc:

I am sending the log from today when this is happening as we speak. It doesnt always happen, but very often. Both on my PC (workstation) and the Render node.

This has also just happened to me. I just updated Pulze on 21 machines and on one single workstation I’m getting this behaviour. I tried the usual troubleshooting (restarting, clean install etc) and nothing works

We have got a similar problem.
We have installed the new render manager version (2210) on our machines.
Only one workstation is making trouble and stuck at “searching programs”.
I’ve tried everything I can think of:
Uninstalling - reinstalling

  • deleting every folder of pulze (AppData etc.)
  • emptying the %temp% folder
  • restarting

Might there be some plugin of max that causes the hang?
Please let me know if you have already a solution for this kind of problem.
Thank you in advance

@office2 @bnuttall could you please send us some logs from the faulty computer to and we will look into it.

I have the same problem after updating to latest version, Searching for programs… on the nodes.
Should I go back to older version or you have a fix for this?


Thanks for the report @nikola! We are looking for a solution, will send you a new build later on that will collect some more information and hopefully we will figure out the problem from that.

Hi @peter.sarhidai any news on this issue?
I tried the beta render manager, now is stuck on Searching for: Pulze Scene Manager on the render nodes.

Hi @nikola

Unfortunately we have not yet figured out what is the issue. We are working on it and will let you know if we find out something.

Same story here, already since previous versions actually, can’t get Pulze RM to start.

Same story as well, searching for Pulze Scene Manager with the latest beta.

Same issue here when installing latest RM. I’m just getting ‘searching for programs’.
This is on a system with a clean install of windows & 3dsmax.
Scene manager works fine.

Could you guys please let us know which version of windows, 3ds Max and what plugins are installed on the computer(s) that has this issue?

2 workstations: One with Windows 11 Pro and one with 11 Pro N + 3ds Max 2023 latest version.

Bercon maps
Octopus (RapidMXS)
Quixel Bridge Megascans
Pulze Scene Manager
Chaos Scatter
Sini Software
Chaos Cosmos
Color Correct
UV by Element

Both workstations display: searching for: Pulze Scene Manager, with the latest beta

One workstation doesn’t have the issue with the latest non beta, but the other workstation is also “searching for programs” with the latest non beta.

Im using windows 11 pro, 3ds max 2024, with Vray 6.20.6, forest pack, Anima, floor generator, multitexture.

I think my problem got fixed when i set the primary Distributor into “workstation” mode not “node” in Render Manager and updated it to the latest version. I feel this solved both my problems, which was the “Searching for programs” being stuck and the render node not starting a job by itself. Im not sure if this was the case or why, but i mention it in case someone else wants to try and maybe solve the issue.

This is my setup on Windows 11 pro 2 machines and is not working.

But, I also have machine with windows server 2016 and is working as should. Probably it is some issue with Windows 11

@ Office 2 - Stuck on ‘Searching For Programs’

I had a similar problem. I found that it was because some of the plugins had not be installed to their default locations on C: drive - I install everything on D: drive .

After some testing I found that the machines with Corona installed in the default location worked, and the ones with Corona installed on D: did not work. Having removed Corona, all machines worked and when I reinstalled Corona - this time to the default location - RM continued to work on all machines (one PC took a couple of tries).

I can’t be sure this will work for you. It might be a different plugin, but this worked for me.

Thank you for your response.

In the end we solved the issue. For us it seemed like a plugin caused the halt.
Unistalling the plugin viz4D (we only tested this a long time a ago) resolved the problem.

Well I don’t want to uninstall all my plugins to find the culprit if it will actually do anything.

I rolled back to 2.2.10 and I moved all plugins in the plugin folder and my whole ENU folder temporarily, to another location to test. I also uninstalled Max 2024 so there’s only 2023. Rebooted, restarted pulze, but still searching for programs.

1 Like