Not saving a stacked EXR (Corona)


Scene Manager has stopped saving EXR images as one stacked EXR? instead it now saves the beauty pass and then all render elements separately. This has now added more time to post production as the individual elements are having to be loaded in. Is there a tick box to allow for a single EXR to be saved with all elements included? Like i say scene manager was happy doing this a few weeks ago. Something seems to have changed.

Thanks in advance


Basically it is a known Max+Corona issue and we started a conversation over here:

Since Corona does not have the V-Ray Raw Output module it is problematic to save EXR/CXR outputs with it. Please let me quote the Corona support:

"Okay so it looks like we can finally reproduce this in one way or another. It seems that there are some issues with saving EXR files.

With the help of Frood, we discovered that this is because 3ds Max saves the EXR saving settings locally on the machine and not in the scene.

This can lead to settings getting mixed up when rendering over a network with backburner. I have sent this over to Autodesk and I’m awaiting their response.

In the meantime, it might be best to set a pre-render script in the scene which sets the EXR file saving settings before each render commences. I hope this can be a suitable workaround for the time being."

So the conclusion is that if you are using Corona since the EXR settings stored on the local machine you have to figure out a company standard EXR save scheme (compressed,uncompressed,layered etc) and set it up one by one on every node once.
In this way you will get a consistent end result.

In the meantime we are working on to handle this behavior more fluently.

If you have any questions, please let me know.

Best regards,


As addition to this topic please let me share a workaround with you. Instead of opening and changing the settings on all the nodes manualy you can overvrite the exr setting file directly. For that please follow these steps:

  • In front of a workstation please open Max and at the render settings/common tab/render output choose the exr and hit “Setup…”.
  • In the pop up EXR settings window setup the way how you would like to save EXR and hit OK
  • After that please go to this folder: “C:\Users\YOURUSERNAME\AppData\Local\Autodesk\3dsMax\2021 - 64bit\ENU\en-US\plugcfg” (Keep in mind the relevant max folder)
  • Over here copy the “fOpenEXR.cfg” file.
  • Paste this file to each and every Node to the same location: “C:\Users\YOURUSERNAME\AppData\Local\Autodesk\3dsMax\2021 - 64bit\ENU\en-US\plugcfg”

As I mentioned in the meantime we fix this issue and in the next update it will be corrected.


think my problem is related to this. so I’m not creating a new topic.
  1. RGB does not change to RGBA until it is changed in the settings of the 3ds. it is ok?
  2. Can you make that after closing the manager, the “save file” check mark in the scene settings returns to the state it was in before opening the manager? so that I don’t need to turn it off after each manager opening